EC20使用AT组件+串口偶尔出现超时是什么问题?

发表在 网络学习营2019-11-4 09:56 [复制链接] 10 636

如题,使用的是最新的AT组件和EC20(4G模块)软件包,但是偶尔会出现超时提醒,请问是什么原因?可以优化解决吗? QQ截图20191104095508.png 9 K  s, D4 {6 p& r! m2 `
使用道具 举报 显示全部楼层 回复
最新评论 | 正序浏览
显示全部楼层 |楼层直达:
发表于 2019-11-4 16:54:32 | 显示全部楼层
如果是偶然出现的话,可以看看硬件连接是不是稳定,也有可能需要优化代码了,,,
使用道具 举报 回复
发表于 2019-11-18 22:52:33 | 显示全部楼层
楼主解决了嘛,我的也是经常超时错误,我裸机程序是正常的
使用道具 举报 回复
发表于 2019-11-19 10:05:58 | 显示全部楼层
梦笑真美 发表于 2019-11-18 22:52
: l, g# B: I/ Z/ {0 d! N楼主解决了嘛,我的也是经常超时错误,我裸机程序是正常的

# t2 `# G( I: k$ a5 G- l5 @0 v3 g建议把 RAW 日志功能打开,需要更多日志信息才能确定问题,从日志中也可能看出那个命令收发失败了
使用道具 举报 回复
发表于 2019-11-26 11:50:59 | 显示全部楼层
梦笑真美 发表于 2019-11-18 22:52
' f5 B4 }7 |8 f( v楼主解决了嘛,我的也是经常超时错误,我裸机程序是正常的
& k+ S) I6 g7 P# l# |" Q- W4 p
暂时还没
使用道具 举报 回复
发表于 2019-11-26 11:51:16 | 显示全部楼层
Cheney_Chen 发表于 2019-11-19 10:05
9 \+ L8 M2 x3 J2 f5 O$ b) a建议把 RAW 日志功能打开,需要更多日志信息才能确定问题,从日志中也可能看出那个命令收发失败了 ...

' u. t  S8 X8 ?  L( V# ~# F" t8 q好的,感谢
使用道具 举报 回复
发表于 2019-12-17 10:35:00 | 显示全部楼层
我也发现了这种情况,暂时还没解决
使用道具 举报 回复
发表于 2020-5-23 11:06:07 | 显示全部楼层
楼主,请教下,你的mqtt是用的rtt中的mqtt软件包么
使用道具 举报 回复
发表于 7 天前 | 显示全部楼层
楼主,解决了吗,我也是偶尔出现超时的情况。
使用道具 举报 回复
发表于 6 天前 | 显示全部楼层
freedom195 发表于 2020-5-23 11:06
5 |; b, z! Y9 P3 \楼主,请教下,你的mqtt是用的rtt中的mqtt软件包么
6 z& F, g, W. I' R
对的
使用道具 举报 回复
发表于 6 天前 | 显示全部楼层
xiakangshun 发表于 2020-5-24 20:265 u3 y2 N; J! y% y' |4 A, @3 p
楼主,解决了吗,我也是偶尔出现超时的情况。
6 v$ H" e, H4 Z6 d
没有,是乎并不影响使用就没管了
使用道具 举报 回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

  1. 15 主题
  2. 271 帖子
  3. 271 积分

Ta的主页 发消息

Archiver|手机版|小黑屋|RT-Thread开发者社区 ( 沪ICP备13014002号-1

有害信息举报电话:021-31165890 手机:18930558079

© 2006-2019 上海睿赛德电子科技有限公司

Powered by RT-Thread

快速回复 返回顶部 返回列表