为什么我用keil仿真出来有pwm但是轮子不动?

2019-7-13 15:15 [复制链接] 5 371

想用pwm控制两个轮子,仿真的时候能看见有pwm输出,但是下载到STM32F103ZET6里就只有一个轮子能动,电机检查过了,没有问题。
: _, I9 y4 _, G* ^( S3 b, c想知道这是什么原因啊?
3 s8 i2 L% h- A) z; k3 I( X1 ]9 j
0 a- v9 G' Q. i' e# V4 ^. F2 U& g) `/ t& Z- ?1 j3 W1 j- X& x" B4 C
7d292e9b2a566986d3633eef22b578b.png
使用道具 举报 显示全部楼层 回复
最新评论 | 正序浏览
显示全部楼层 |楼层直达:
发表于 2019-7-13 15:25:54 | 显示全部楼层
你电机是用的什么驱动呢?驱动器控制引脚直接接 VCC 应该是可以转的把。3 J: Q& }7 d- I+ F4 `5 X3 t

" K3 `# j1 H) K& r- h如果电机驱动没问题,PWM能正常输出的话,应当也是没问题的
使用道具 举报 回复
发表于 2019-7-13 16:35:42 | 显示全部楼层
wuhanstudio 发表于 2019-7-13 15:251 g7 M1 O* R) G4 |0 c" A
你电机是用的什么驱动呢?驱动器控制引脚直接接 VCC 应该是可以转的把。
% A5 c+ g1 r  H4 @" @- r- h% c2 l( }1 G: F0 ~
如果电机驱动没问题,PWM能正常输 ...

8 Q3 f; ^1 c! _用的是TB6612FNG芯片驱动的,这就比较纳闷儿了,两个口一样的配置方法,一样的pwm输出,
使用道具 举报 回复
发表于 2019-7-13 19:48:49 | 显示全部楼层
wuhanstudio 发表于 2019-7-13 15:254 m- a! h' {8 o  J! ^# @
你电机是用的什么驱动呢?驱动器控制引脚直接接 VCC 应该是可以转的把。
& @* S! X. ^- J5 r; f) J2 w) Q& j1 d  N- |* u
如果电机驱动没问题,PWM能正常输 ...
1 x' h7 @8 F8 N% w3 e
我用示波器看了看,有一个口输出的pwm波形和仿真时候的波形不一样,这种情况怎么解决啊
7 J" `. ~  \" C( m' D, W
使用道具 举报 回复
发表于 2019-7-16 13:58:15 来自手机 | 显示全部楼层
你可以检查一下 bsp/board 里面 CubeMX 的配置,外设和时钟什么的,和你仿真用的是不是一样的,重新 CubeMX 生成一下启动代码
使用道具 举报 回复
发表于 2019-7-16 14:16:43 | 显示全部楼层
小鑫鑫 发表于 2019-7-13 19:48
/ T+ l  c7 ], u+ @我用示波器看了看,有一个口输出的pwm波形和仿真时候的波形不一样,这种情况怎么解决啊/ \/ M4 E4 L7 e+ A! `% J6 G. H
...

; T. u/ Z3 x8 V1 f: Z  |波形图贴出来?
使用道具 举报 回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|RT-Thread开发者社区 ( 沪ICP备13014002号-1

有害信息举报电话:021-31165890 手机:18930558079

© 2006-2019 上海睿赛德电子科技有限公司

Powered by RT-Thread

快速回复 返回顶部 返回列表