【Env工具】:有问题的小伙伴来找我就对了

置顶 精华 发表在 Env2018-1-2 16:43   [复制链接] 524 31483

发表于 2018-11-13 13:22:47 | 显示全部楼层
提示:
0 k, k# }9 e, k1 @; |# Qscons: warning: No version of Visual Studio compiler found - C/C++ compilers most likely not set correctly
/ A; A0 _8 w: A: h. IFile "D:\Work\1_Lsd\Sdk\Rtt\rt-thread\bsp\w600\SConstruct", line 32, in <module>$ K5 {% B) M+ X- k7 N7 e

1 I6 i( n' f% z. g( R, @( aFile -> Sconstruct 的 line32 是  Export('RTT_ROOT'),我看了一下程序运行到这个地方,输出的是RTTHREAD的绝对路径。
, i% c6 |  k4 b) p/ J" ~. i* w3 T
我用的是keil的环境  keil5  已经配置过了
( V4 ~7 c/ q4 b. g$ Nelif CROSS_TOOL == 'keil':1 \) Z' u! X5 U- T
        PLATFORM         = 'armcc'& u4 g6 w$ b% a
        EXEC_PATH         = 'C:/Keil_v5'7 W2 q$ l2 j: J, B  C

, e2 D* D8 v4 ]# \5 C( q- g: {( j4 Y" \+ p/ z9 g
现在不明白是哪里的问题,  c/c++的环境还要装吗?   怎么处理。
" {" \# y& u+ M3 `- R! _9 h8 z, d4 f
使用道具 举报 回复
发表于 2018-11-13 18:30:46 | 显示全部楼层
lvx 发表于 2018-11-13 13:22  m- X2 _6 K3 S2 F, ~2 z
提示:
, b: V5 V6 k$ F# m  `8 Rscons: warning: No version of Visual Studio compiler found - C/C++ compilers most likely not  ...

; e0 h% I0 C. Y8 j- c4 ]' d$ @这个警告可以忽略
使用道具 举报 回复
发表于 2018-11-18 16:35:31 | 显示全部楼层
> pkgs --upgrade+ N: E! G  M( [9 h
e.message:HTTPConnectionPool(host='127.0.0.1', port=1080): Max retries exceeded with url: http://packages.rt-thread.org/packages/queries (Caused by ProxyError('Cannot connect to proxy.', NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x0000000003B9CEB8>: Failed to establish a new connection: [Errno 10061] ',)))- |! w, C( L- L% p$ Z# M5 @

) v- f$ G1 z$ M! ^2 V6 u( j% u( uThe server could not be contacted. Please check your network connection./ O- O* O1 B7 \0 e4 C: h9 k6 T) ?( B
Traceback (most recent call last):9 b) L; W5 v# O" P1 f! q
  File "E:\Git\env_release\env\tools\ConEmu\ConEmu\..\..\..\tools\scripts\env.py", line 70, in <module>) d  o" K: \3 q+ k+ Y
    main()0 E3 U" i9 _8 W
  File "E:\Git\env_release\env\tools\ConEmu\ConEmu\..\..\..\tools\scripts\env.py", line 66, in main
. }0 Z0 k/ @% i  |- i& p    args.func(args)
3 d# e9 a& p. ?- Z) U# w% o  File "E:\Git\env_release\env\tools\scripts\cmds\cmd_package.py", line 1046, in cmd
5 M. u' n* W' G" W+ I    package_upgrade()& D' d6 l" w; v' ?
  File "E:\Git\env_release\env\tools\scripts\cmds\cmd_package.py", line 1013, in package_upgrade
9 y7 b& ]. X$ k- d( E8 Q    upgrade_packages_index()
, W1 \$ p) b' W1 Z0 p  File "E:\Git\env_release\env\tools\scripts\cmds\cmd_package.py", line 947, in upgrade_packages_index
# z, c5 h; H% j    get_package_url, get_ver_sha = get_url_from_mirror_server('packages', 'latest')
- {  c& {0 m5 T$ E8 w8 S7 b3 _TypeError: 'NoneType' object is not iterable5 W5 x: s0 B- A- v' K4 \$ [
无法更新是怎么,求教
使用道具 举报 回复
发表于 2018-11-19 10:07:53 | 显示全部楼层
111 发表于 2018-11-18 16:35
1 F$ V$ N& U$ {> pkgs --upgrade2 U7 z5 u( T) ~
e.message:HTTPConnectionPool(host='127.0.0.1', port=1080): Max retries exceeded wit ...
5 v% b  Z7 B6 r2 O! b
你这个是连不上网的呀,尝试 menuconfig -s 把镜像关了再下载试试看。
使用道具 举报 回复
发表于 2018-11-19 11:39:10 | 显示全部楼层
Summer_gift 发表于 2018-11-19 10:076 i7 P& \3 E1 n" E1 v9 \
你这个是连不上网的呀,尝试 menuconfig -s 把镜像关了再下载试试看。
2 F3 \7 \. e5 s4 Z  I/ a! _) k; {
确实是这样,请问这是什么原因?
使用道具 举报 回复
发表于 2018-11-19 13:53:47 | 显示全部楼层
111 发表于 2018-11-19 11:39: m0 J& ?4 l' [, e4 `
确实是这样,请问这是什么原因?
2 j. D  O/ \5 `; `7 I7 `
就是暂时连不上镜像服务器,我这边试了试目前可以用的。不知道你那边网络是否正常。关了镜像能下载了吗?% [8 _! R$ {  J- T8 C/ j/ `
使用道具 举报 回复
发表于 2018-11-19 18:58:47 | 显示全部楼层
Summer_gift 发表于 2018-11-19 13:53) N! D% Q1 |* r# g5 {
就是暂时连不上镜像服务器,我这边试了试目前可以用的。不知道你那边网络是否正常。关了镜像能下载了吗?. j9 R1 d" Q( m* ]
...
( W: [& n5 R* r( g- Q
是的,关上了可以,谢谢,
使用道具 举报 回复
发表于 2018-11-19 19:08:27 | 显示全部楼层
Summer_gift 发表于 2018-11-19 13:537 `: j! Z6 n, l9 g
就是暂时连不上镜像服务器,我这边试了试目前可以用的。不知道你那边网络是否正常。关了镜像能下载了吗?* h( E2 V8 ^  v3 c: m- }. D
...
0 b4 k! R/ ^8 E- i7 f4 A
但是此时,编译又出现问题:
, J  o, Z- @% [: F> scons  j1 y5 s5 V. ?8 |! Z( i3 {
scons: Reading SConscript files ...6 @8 d$ T0 P" a+ U# @  c" {8 S
. A  z& p( X" z1 o
scons: warning: No version of Visual Studio compiler found - C/C++ compilers most likely not set correctly: A  ^% ^# X  b- L3 {' c7 g
File "E:\RT-Thread\rt-thread-master\rt-thread-master\bsp\qemu-vexpress-a9\SConstruct", line 23, in <module>" h1 g. c2 [# E+ E- I
scons: done reading SConscript files.
. F8 H& s2 C& r7 ]scons: Building targets ...* u7 J" J* i2 A: ^
scons: building associated VariantDir targets: build4 o, r. p9 L7 r
CC build\applications\lcd_init.o
4 g( y& F; O( o5 v% m$ JIn file included from E:\RT-Thread\rt-thread-master\rt-thread-master\components\net\sal_socket\include\dfs_net\sys_select/sys/select.h:28:0,4 S& m! u+ n% i/ Y8 B" q
                 from e:\git\env_release\env\tools\gnu_gcc\arm_gcc\mingw\arm-none-eabi\include\sys\types.h:68,, {) c% @, r5 U3 n2 t' R
                 from e:\git\env_release\env\tools\gnu_gcc\arm_gcc\mingw\arm-none-eabi\include\sys\signal.h:12,9 Y! @" m! f) A5 I6 v
                 from E:\RT-Thread\rt-thread-master\rt-thread-master\include/libc/libc_signal.h:71,9 a6 a8 d5 Q0 Z' ^
                 from E:\RT-Thread\rt-thread-master\rt-thread-master\include/rtdef.h:448,
. V1 C" u4 ]* h" z& H, `! A                 from E:\RT-Thread\rt-thread-master\rt-thread-master\include/rtthread.h:27,2 C8 F1 l6 }* a" w9 `
                 from applications\lcd_init.c:1:$ S- ~; f+ ^; l/ J- c# w7 s) n% }
E:\RT-Thread\rt-thread-master\rt-thread-master\components\dfs\include/dfs_select.h:24:22: error: unknown type name 'fd_set'
: S7 u2 e% r/ e; b2 j% |  ^ int select(int nfds, fd_set *readfds, fd_set *writefds, fd_set *exceptfds, struct timeval *timeout);+ T+ K9 a+ D. J- G5 d: }/ {$ q! c  n
                      ^
+ L5 E' ]% k" }6 M% rE:\RT-Thread\rt-thread-master\rt-thread-master\components\dfs\include/dfs_select.h:24:39: error: unknown type name 'fd_set'
& L* O) L. A: F! \1 x! Z int select(int nfds, fd_set *readfds, fd_set *writefds, fd_set *exceptfds, struct timeval *timeout);) l( x9 t( K5 P
                                       ^% Y& }: X" a- z
E:\RT-Thread\rt-thread-master\rt-thread-master\components\dfs\include/dfs_select.h:24:57: error: unknown type name 'fd_set'
8 V2 I, R0 P# ?: K1 L- c: K int select(int nfds, fd_set *readfds, fd_set *writefds, fd_set *exceptfds, struct timeval *timeout);
( w) S8 w7 i3 ^" u3 ^2 H7 q                                                         ^
% D; l' p! e# u5 v7 C/ zscons: *** [build\applications\lcd_init.o] Error 10 {' b% e. l  B
scons: building terminated because of errors.2 n7 M5 m7 a- |, D8 U" }
以前编译的时候不会,突然冒出来没定义
使用道具 举报 回复
发表于 2018-11-20 21:56:35 | 显示全部楼层
111 发表于 2018-11-19 19:08; r4 F" Q' Z' p' g. I$ A
但是此时,编译又出现问题:
3 O; N5 `7 [: s) ^# V" J> scons  h3 X# P- c. {+ P! \, K! g
scons: Reading SConscript files ...

% ?8 a) c% O. _/ m( ?+ f3 H$ T# ]你这是哪个 BSP 啊,你这些看起来都是一些非常古老已经解决过的问题,推荐你去 git 下载最新版的 BSP 使用。
使用道具 举报 回复
发表于 2018-11-21 09:14:03 | 显示全部楼层
Summer_gift 发表于 2018-11-20 21:566 v) {7 c2 b4 I3 H% p2 Y& [& O; W& k
你这是哪个 BSP 啊,你这些看起来都是一些非常古老已经解决过的问题,推荐你去 git 下载最新版的 BSP 使用 ...
9 l. R# }2 W0 ^6 J
哈哈,出书的时候下的
使用道具 举报 回复
发表于 2018-11-21 10:59:16 | 显示全部楼层
Summer_gift 发表于 2018-11-20 21:56( w3 X1 j3 K+ @+ Q0 F
你这是哪个 BSP 啊,你这些看起来都是一些非常古老已经解决过的问题,推荐你去 git 下载最新版的 BSP 使用 ...
& `+ s5 Y* x0 A/ y$ _% S
重新下载了源码,可以了,谢谢
使用道具 举报 回复
发表于 2018-11-22 10:51:42 | 显示全部楼层
111 发表于 2018-11-21 10:59/ D) k- u) t, t1 I$ i& r
重新下载了源码,可以了,谢谢

- a8 W+ x. m7 X% ^/ M6 X/ | 这样啊
使用道具 举报 回复
发表于 2018-11-22 11:06:24 | 显示全部楼层
Summer_gift 发表于 2018-10-29 17:11
- V/ C3 C# |  a4 I我也没发现,应该是当前版本没有了这个配置项。
' q; x3 [1 w9 ~/ Z+ n1 G
恩,所以我就自己加了一个上去。这个后续的话应该可以加到ENV里头去的哦?
使用道具 举报 回复
发表于 2018-11-22 22:18:25 | 显示全部楼层
1.git获取源码: H) R% T; P4 s' t4 W+ ], A4 \* M: u
2.进入\rt-thread\bsp\qemu-vexpress-a9
6 C( ~) u2 Q/ O, H3.menuconfig   启用gui 及gui example. M; m% Q# ~1 }1 i4 J0 }
4.scons9 s% }: ]8 p6 F" w! v7 n# G
5.下图的错误+ f& V# n+ _* }& l3 B/ k- x3 h% @* p
无标题.jpg 6 D/ @* E7 T' P3 w7 q
麻烦 帮看看,新手,无从下手有点" C& b! |, f! J
使用道具 举报 回复
发表于 2018-11-23 10:40:14 | 显示全部楼层
jingyes239 发表于 2018-11-22 22:18
( L9 v' G" I5 S2 n: n1.git获取源码" T3 i5 K" D1 ]- T% ^
2.进入\rt-thread\bsp\qemu-vexpress-a9! N6 C3 ~3 Y  j# m7 g* {
3.menuconfig   启用gui 及gui example
& R9 D6 k! s( f( V& D! g% q) Z
我帮你 @ 软件包的管理人员了
使用道具 举报 回复
发表于 2018-11-25 06:44:36 | 显示全部楼层
jingyes239 发表于 2018-11-22 22:18
- b( ^9 G2 L7 P/ G9 O/ G9 q1.git获取源码
% a9 K& D/ c; {/ k3 N( y$ q: A' s- H2.进入\rt-thread\bsp\qemu-vexpress-a9
3 r% d2 A5 i" G# D* U' u) ]8 e3.menuconfig   启用gui 及gui example
  B; t; K" y  F% Q: a+ t; P" i
选择最新版本试试?
使用道具 举报 回复
发表于 2018-11-28 21:45:07 | 显示全部楼层
我这里遇到一个问题,是关于cmd的,下面贴图

系统版本

系统版本

就常见出错中的路径也是添加了

就常见出错中的路径也是添加了

具体报错内容

具体报错内容
使用道具 举报 回复
发表于 2018-11-28 21:46:10 | 显示全部楼层
鱼窥荷 发表于 2018-11-28 21:45
9 l; r% m! h4 U5 ~; ^我这里遇到一个问题,是关于cmd的,下面贴图

- k% W4 h' \  S8 b; lenv工具使用的是最新的1.0.0
使用道具 举报 回复
发表于 2018-11-29 11:11:05 | 显示全部楼层
本帖最后由 Owen 于 2018-11-29 11:14 编辑
9 x4 ^- t$ x, L' T* v+ l. ?1 y/ X6 \# |7 u
请问用哪个指令可以查看env自身的版本号?
使用道具 举报 回复
发表于 2018-11-29 17:17:10 | 显示全部楼层
本帖最后由 Summer_gift 于 2018-11-29 17:20 编辑
/ @1 A' n* n& J) y
Owen 发表于 2018-11-29 11:11
1 }9 g$ z( t$ l1 C请问用哪个指令可以查看env自身的版本号?
- V7 {+ s% ]( N2 s$ R. s
目前可以在env 根目录中查看 changelog,目前可以根据 pkgs --upgrade 将功能代码更新到最新
使用道具 举报 回复
发表于 2018-11-29 17:17:47 | 显示全部楼层
鱼窥荷 发表于 2018-11-28 21:46) G( H7 X7 `6 w3 W2 a" L
env工具使用的是最新的1.0.0
6 E5 w/ Z- _" X. s% b9 ?
那你需要看看你电脑里面 cmd 的路径是在哪里,然后加入到系统环境变量里面就可以了。
使用道具 举报 回复
发表于 2018-11-29 18:41:58 | 显示全部楼层
照化 发表于 2018-5-9 14:25
8 o0 X. m4 F& f$ [) w0 {4 V" K3 V在bsp中stm32f429-apollo中操作:
0 s( S# Z. n' G1 p# Q
我也遇到过这样的问题,我是这样解决的C盘->用户->用户账户的名称(装系统时设置的),看看是不是中文的   如果是中文的就把他改成英文的   有的不能重命名那就去把目前的账户换成管理员账户   不知道是不是这样的。
使用道具 举报 回复
发表于 2018-11-29 21:01:22 | 显示全部楼层
Summer_gift 发表于 2018-11-29 17:17
8 L  t/ u; L; j) J. E) r; N那你需要看看你电脑里面 cmd 的路径是在哪里,然后加入到系统环境变量里面就可以了。 ...

8 X" N8 ?: b# K/ [* e7 y: q我电脑里cmd的路径就在这儿3 b" m- P' T- I6 V1 c" a$ A, P; F
1.jpg
使用道具 举报 回复
发表于 2018-11-30 09:28:22 | 显示全部楼层
鱼窥荷 发表于 2018-11-29 21:01
0 J" y0 a% H3 d6 d: j4 V7 x/ }我电脑里cmd的路径就在这儿
/ q) }7 @! Y/ L4 R, ]* R0 Y
那会不会是用户 windows 用户不对呢?
& p. R1 n' ]5 ]( B4 g你这个就有点奇怪了
使用道具 举报 回复
发表于 2018-11-30 11:32:20 来自手机 | 显示全部楼层
在windows版env中有menuconfig -s配置自动更新在线软件包(menuconfig完后自动执行pkgs --update),我想知道在linux版env中有没有类似操作,我用scons --menuconfig -s试了下,似乎并不接受这个额外的-s参数,有没有人能为我解答一下
使用道具 举报 回复
发表于 2018-11-30 13:58:59 | 显示全部楼层
输入menuconfig  出现Kconfig:1: can't open file "/src/Kconfig" ,何解?8 N# Q0 k7 v% L6 t) ]* ^
menuconfig出错.PNG
使用道具 举报 回复
发表于 2018-11-30 16:16:11 | 显示全部楼层
本帖最后由 Summer_gift 于 2018-11-30 16:19 编辑 % k, d( Q3 ~4 L: m. S( O
haisen668 发表于 2018-11-30 13:58* ?2 j4 X1 r5 u$ {8 K- A9 Y( W
输入menuconfig  出现Kconfig:1: can't open file "/src/Kconfig" ,何解?
1 o2 v9 ^/ C9 h% j' b
rt-thread 代码不完整吧,你检查一下代码,有没有这个文件。如果没有,那么可以下载一个最新版本的 rtt 使用。% n- l7 Z" V( K6 Q1 X4 w* B
使用道具 举报 回复
发表于 2018-11-30 16:21:48 | 显示全部楼层
jzz 发表于 2018-11-30 11:32
/ _5 v) x9 r0 o% G/ G: z在windows版env中有menuconfig -s配置自动更新在线软件包(menuconfig完后自动执行pkgs --update),我想知道 ...
+ |6 r+ l  B8 a/ n. I) y- b
应该是可以的吧
使用道具 举报 回复
发表于 2018-11-30 21:59:25 | 显示全部楼层
Summer_gift 发表于 2018-11-30 16:21! ~1 A4 H1 p& E: ^2 F4 t; k$ |
应该是可以的吧
9 @& D+ A' t, X% N. W5 r
可实践证明不可以=-=
使用道具 举报 回复
发表于 2018-12-1 14:32:29 | 显示全部楼层
Summer_gift 发表于 2018-11-30 16:16
' d1 g  C" d$ s( ?' @& Crt-thread 代码不完整吧,你检查一下代码,有没有这个文件。如果没有,那么可以下载一个最新版本的 rtt 使 ...

5 x/ U1 E8 n4 C) ]0 S3 r4 @% S感谢
使用道具 举报 回复
发表于 2018-12-1 15:05:21 | 显示全部楼层
Summer_gift 发表于 2018-11-30 16:16
6 D' z3 b# n7 o1 o# ?+ _rt-thread 代码不完整吧,你检查一下代码,有没有这个文件。如果没有,那么可以下载一个最新版本的 rtt 使 ...

. x( ^0 `- v2 _- l7 s7 V/ Y你好,想请教一下啊,我现在有一个NB-IOT 芯片, 是用串口接到STM32L433 芯片上,如何把NB-IOT 芯片的AT 命令移植到 RTthread 中,有没有相关参考。
使用道具 举报 回复
发表于 2018-12-1 19:40:10 | 显示全部楼层
haisen668 发表于 2018-12-1 15:05
% W9 Q. y; p- _( B# {; q你好,想请教一下啊,我现在有一个NB-IOT 芯片, 是用串口接到STM32L433 芯片上,如何把NB-IOT 芯片的AT  ...

8 }0 P! d$ s+ [可以去文档中心关于 at 组件的内容
使用道具 举报 回复
发表于 2018-12-3 17:44:53 | 显示全部楼层
请问一下:使用env生成的MDK工程,手工添加了自己编写的文件,一段时间后,再次通过env往工程添加其他组件,会出现自己编写的文件被删除的现象,应该怎么解决?谢谢
使用道具 举报 回复
发表于 2018-12-3 18:09:04 | 显示全部楼层
yangweibo 发表于 2018-12-3 17:44, L& @2 @/ u% p
请问一下:使用env生成的MDK工程,手工添加了自己编写的文件,一段时间后,再次通过env往工程添加其他组件 ...
& ^5 K  h+ i+ r" n! o% k
修改 sconscripts  文件将你手动添加的文件写在构建脚本里,重新生成就可以了
使用道具 举报 回复
发表于 2018-12-12 00:15:16 | 显示全部楼层
你好,我刚安装完ENV,运行就报错误,输入任何指令都没有效,请问这是什么问题呢,谢谢!界面显示如下:
- H4 M6 ?2 r4 U. O4 Y+ m8 a+ H
Clink vDEV [git:96d1a6] Copyright (c) 2012-2016 Martin Ridgers2 \# N. t& s5 D( B( I* `8 v" s7 i# S+ ~
http://mridgers.github.io/clink; j+ ~4 M6 X( J8 U; Z

5 D. h3 ?$ o' vMicrosoft Windows [版本 6.1.7601]: F9 T, f: K  O/ N/ {  e" M3 R, `! b
此时不应有 \env\tools\ConEmu\ConEmu\..\..\..\tools\Python27_32。8 K2 L- E' |; N) W6 Z
D:\Program Files (x86)\env8 H5 J" U! u' Y+ Q
D:\Program Files (x86)\env>4 ]! P' u+ l& ?& S4 j2 M6 X, G
D:\Program Files (x86)\env>( U0 A: p* A6 m8 J# `8 P
D:\Program Files (x86)\env>
; c) n* n* }2 @+ d2 O) d1 U
使用道具 举报 回复
发表于 2018-12-12 14:03:03 | 显示全部楼层
平台:win10;3 _! E* r% \/ z8 r( c; m1 m/ n
env版本:1.0.0;1 Q" H$ ?" D6 D2 F

2 @, l# c0 k& r2 k新clone的工程,运行menuconfig会出现如图片所示的错误!/ K6 {. k: D. d1 Y9 w
9 B3 o1 q6 P& V+ L+ \( I# Y

* i7 u/ [9 ]$ u4 ]) x$ E" l9 r, m) R
TIM截图20181212140105.png
使用道具 举报 回复
发表于 2018-12-12 17:42:07 | 显示全部楼层
serstar 发表于 2018-12-12 14:030 \$ f; ^7 g* f# e( o
平台:win10;
2 }+ m2 R+ a7 Lenv版本:1.0.0;

* `5 d  S7 h, M% G! H8 b  J# k% ]你看一下有没有这个文件呢?
使用道具 举报 回复
发表于 2018-12-12 17:44:47 | 显示全部楼层
jgp886585 发表于 2018-12-12 00:15' F2 V+ ^: h7 e4 \8 j
你好,我刚安装完ENV,运行就报错误,输入任何指令都没有效,请问这是什么问题呢,谢谢!界面显示如下:
7 L/ v+ F) w, m( ]. X9 d8 k/ b) \
C ...
  @* r+ {2 M5 b1 K) z, `
你这个问题是 env 的安装路径有空格
使用道具 举报 回复
发表于 2018-12-12 20:22:33 | 显示全部楼层
Summer_gift 发表于 2018-12-12 17:44+ w* x( V7 Z% v
你这个问题是 env 的安装路径有空格
2 W8 o; k9 d: r( N2 W& ]2 ^. V
好的,谢谢,我改个路径试下,非常感谢
使用道具 举报 回复
发表于 2018-12-12 20:25:45 | 显示全部楼层
jgp886585 发表于 2018-12-12 20:226 ~6 H) i( f* v7 S4 k
好的,谢谢,我改个路径试下,非常感谢
( O1 z) D5 ?2 q  z$ ?5 E
可以了,谢谢
使用道具 举报 回复
发表于 2018-12-13 09:46:39 | 显示全部楼层
本帖最后由 serstar 于 2018-12-13 10:03 编辑 $ w$ @7 V8 I  r" H3 z, t
Summer_gift 发表于 2018-12-12 17:42
8 Y' D# L% T! `& a! W你看一下有没有这个文件呢?

! |5 ?7 p' l+ N1 C" m找到问题了,是环境变量设置错了,之前设置没有加stm32f10x,按照图片这样设置就对了!' y  M9 X- X) S3 y# V! i
& I3 ~8 t/ C: o: B$ E

$ M  b. H8 Q6 c3 I6 I
TIM截图20181213100117.png
使用道具 举报 回复
发表于 2018-12-13 11:08:15 | 显示全部楼层
serstar 发表于 2018-12-13 09:46
/ j2 ]+ ?2 p7 Y7 |* r! m找到问题了,是环境变量设置错了,之前设置没有加stm32f10x,按照图片这样设置就对了!

9 B4 l! J2 `! ~6 g6 ?应该说是不需要手动设置任何环境变量的,你这个也是有些奇怪。
使用道具 举报 回复
发表于 2018-12-13 15:13:55 | 显示全部楼层
Summer_gift 发表于 2018-12-13 11:087 U( G8 B! p" `! s- y
应该说是不需要手动设置任何环境变量的,你这个也是有些奇怪。
# k' V# j. a+ Z
可能还是别的问题引起的,我再找找
使用道具 举报 回复
发表于 2018-12-13 22:53:57 | 显示全部楼层
你好,RTT的第一个官方视频例程QEMU QQ图片20181213225316.png ,创建的时候有2个使能,但是我在配置的时候只找到一个,然后按照操作运行后出现的是空白界面,而不是视频中出现的欢迎界面,还要配置哪里呢,谢谢
使用道具 举报 回复
发表于 2018-12-14 20:12:54 | 显示全部楼层
jgp886585 发表于 2018-12-13 22:53
' q1 A$ f$ V: W- ~% ^6 ~5 Z你好,RTT的第一个官方视频例程QEMU,创建的时候有2个使能,但是我在配置的时候只找到一个,然后按照操作运 ...

+ h" c3 d5 i3 f2 l- j! ?: nqemu 的使用问题可以在其他版块发帖哦
使用道具 举报 回复
发表于 2018-12-18 19:22:21 | 显示全部楼层
* p# i! r  @# g( V
按着官网那个快速上手配置env,到scons那一步时就出现下图情况,代码、env都是最新的,请大佬们帮帮忙
1 w# |$ s0 H+ `3 G 1.jpg
2 i) \. M- g$ Z3 |6 [- ^( H+ K
使用道具 举报 回复
发表于 2018-12-18 19:39:35 | 显示全部楼层
adol 发表于 2018-12-18 19:22
1 v. o% z. G. m按着官网那个快速上手配置env,到scons那一步时就出现下图情况,代码、env都是最新的,请大佬们帮帮忙
7 v' B! m+ G# [# i# n, Q1 v% L6 Z& W- N  Q
...

7 P& U$ c$ {) P+ n这是软件包代码出问题了呀
使用道具 举报 回复
发表于 2018-12-18 19:46:56 | 显示全部楼层
adol 发表于 2018-12-18 19:22) T! ?% L& \, J" H) G% C
按着官网那个快速上手配置env,到scons那一步时就出现下图情况,代码、env都是最新的,请大佬们帮帮忙
" b2 n. y: l1 H/ @/ G8 M: u* e  u( @2 g1 `+ G5 n( i2 I5 N
...

6 c+ E, U1 S3 L% t, g具体按照哪个文档进行操作的呢?
使用道具 举报 回复
发表于 2018-12-19 13:22:14 | 显示全部楼层
yqiu 发表于 2018-12-18 19:46
) _: [, m7 n# ~% E/ s具体按照哪个文档进行操作的呢?

" O' b4 O( q* W' V+ i( E我是按照这个视频弄得http://www.moore8.com/courses/19129 R3 s( c  H6 _7 H% {( s$ l5 m
大概在5分钟开始按着她的操作  在路径\rt-thread\bsp\qemu-vexpress-a9下输入menuconfig开启配置页面后,
3 L. _- G& ^' ?/ b$ J进入RT-Thread online pack→system packages→选中了RT-Thread GUI Engine后→进入该项选中了Enable the example of GUI Engine." z) p8 G7 y8 l, a+ X+ a
9 ~8 N6 t4 O* |0 Q$ t/ |
( Q0 Z; I1 X! D; u5 T% b7 f) Z
2.png / e0 D+ V" `6 Y& C  X/ m
然后保存退出,scons就出现那个错误了。。。
; T/ D3 I5 m( ?
使用道具 举报 回复
发表于 2018-12-19 14:52:15 | 显示全部楼层
adol 发表于 2018-12-19 13:22
3 n/ O2 ^- o4 }, U) U7 U我是按照这个视频弄得http://www.moore8.com/courses/1912,# [7 L: l! B8 a4 o* L2 b
大概在5分钟开始按着她的操作  在路径\rt-th ...

/ h8 M' @. C0 X* Z" K; Bhttps://www.rt-thread.org/docume ... u_setup/qemu_setup/ 参考这个官网的视频教程来吧;
使用道具 举报 回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|RT-Thread开发者社区 ( 沪ICP备13014002号-1

有害信息举报电话:021-31165890 手机:18930558079

© 2006-2019 上海睿赛德电子科技有限公司

Powered by RT-Thread

快速回复 返回顶部 返回列表